Eclipse lädt Plug-ins der View nicht mehr

Mir ist heute folgendes passiert. Mein Laptop ist leider aufgrund seines leeren Akkus ausgegangen als ich Eclipse noch offen hatte und selbst nicht da war. Dumm gelaufen. Als ich mein Eclipse nach Neustart dann wieder öffnen wollte, hab ich Exceptions von Eclipse und nicht etwa die von mir geschriebene Klasse zu sehen bekommen. Selbst der Package Explorer, die JUnit-View und gar der Wizard für ein neues Projekt konnten nicht mehr geladen werden. Eine Lösung für das Problem habe ich glücklicherweise doch noch gefunden.

Die Exceptions waren dieser Art:

Den gesamten Stacktrace habe ich mal getrost weggelassen, da es definitiv zu viele Exceptions waren und ich nur noch diese in meiner Zwischenablage hatte.

Meine Recherche im Netz blieb leider erfolglos. Zwar bin ich auf Bug-Pages von Eclipse gestoßen, aber die haben mich nicht zu meinem Ziel gebracht.

Ich musste also rumprobieren. Das Wechseln der Perspektiven hat mir gezeigt, dass andere Perspektiven zwar zum Teil funktionieren, aber meine Java-Perspektive konnte nach dem Rückwechsel noch immer nicht geladen werden. Der Eclipse-Neustart  blieb ebenso erfolglos. Meine rettende Idee war letzten Endes das Wechseln meines Workspaces. Nachdem ich einen anderen Workspace geöffnet habe und dieser erfolgreich geladen wurde, probierte ich es also wieder mit dem Problem-Workspace und siehe da – es geht wieder!

Wenn das nächste mal der Workspace nicht mehr lädt, also einfach Workspace hin und her wechseln.

Marlene Knoche Verfasst von:

Informatikerin mit Hang zur Kunst. - Theaterbegeistert, mag Katzen und Kaffee.

Schreibe den ersten Kommentar

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Time limit is exhausted. Please reload CAPTCHA.